Dans cet article, vous trouvez un aperçu des erreurs les plus courantes que vous pouvez rencontrer dans l'intégration entre Octopus et Teamleader Focus. 


La période de l'exercice est fermée

Causes possibles :


  • L'exercice est déjà clôturé dans Octopus, ce qui signifie qu'aucune facture ne peut y être ajoutée.
  • La période (trimestre ou mois, par exemple) est déjà clôturée dans Octopus, ce qui signifie qu'aucune facture ne peut y être ajoutée.


Solution :

  • Rouvrir l'exercice (Gestion > Journaux > Exercice X)
  • Rouvrir la période (Gestion > Journaux > Exercice X > Fermé jusqu'à la période / Sécurisé jusqu'à la période) .
  • La période de "Fermé jusqu'à la période / Sécurisé jusqu'à la période" doit être inférieure (par ex. 201901) à la "Période active" ou à la période que vous souhaitez comptabiliser (par ex. 201902).

Le journal est d'un type qui ne convient pas

Le "Journal V1" dans Octopus est d'un type qui ne convient pas. Ce devrait être 'Énregistrements Vente'.


Solution :


  • Dans Octopus, allez dans Gestion > Journaux
  • Modifiez le  « Type d’introduction »  en « Énregistrements Vente » . Vous trouverez plus d'informations ici.



Je ne peux pas sélectionner les journaux dans le Marketplace, néanmoins la configuration des journaux dans Octopus est correcte


Cause :


  • Si les journaux ont été créés récemment, ils ne sont pas encore disponibles via l'API. Pour cette raison, ils ne sont pas disponibles dans le Marketplace Teamleader Focus.



Solutions :


  • Dans Octopus, vous pouvez cliquer sur Fichier (coin supérieur gauche, assurez-vous que le bon compte est actif) et sélectionner 'Synchroniser'.
  • Les journaux seront ainsi mis à la disposition de l'API.
  • Ensuite, vous pouvez retourner au Marketplace et cliquer à nouveau sur "Lier dossier".
  • Les journaux manquants devraient maintenant s'afficher dans le menu déroulant " Journal factures / Journal notes de crédit" 


Un item de la facture n'avait pas de compte sélectionné pour la facture X


Cause :

  • Un item de facture a un compte inconnu

Solutions :

  • Allez à l'aperçu des factures et ouvrez la facture correspondante. Cliquez sur le crayon à côté de "contenu" pour ajouter le compte correct (il ne devrait pas être inconnu) :
  • Si vos comptes sont liés à votre taux de TVA, vous pouvez faire cela en action groupée dans paramètres > factures > compte > suggestion automatique de certains taux de TVA.